解决,路由版本太高,装了下面版本就不报错了
npm install vue-router@3.5.3

npm install

npm run dev